PairwiseIdDataConnectorParser does not derive from the data connector parser base class
Description
Environment
Confluence content
Activity
Rod WiddowsonNovember 3, 2022 at 10:25 AM
I’ll make sure that the three all align as part of this work.
Based on what I see in the docs, seems like we must have intended it to support the common attributes.
Given that it will be hard to document things otherwise I’d agree - we would be better served to support them all and issue watrnings if they make no sense (e.g. failFast makes no sense on a computedIdConnector, so it could warn about it. But it should be an acceptable setting).
Scott CantorNovember 2, 2022 at 5:31 PM
We’d really need to carefully review the docs + schema + code and make sure it’s lining up I guess. Based on what I see in the docs, seems like we must have intended it to support the common attributes.
Rod WiddowsonNovember 2, 2022 at 5:16 PM
I take that back. Adding the derivation from the data connector adds all sorts of extra requirements on the impl class (at leastsetFailFastInitialize(boolean)
The code for the asbtract parser states that failfast
// LDAP, Relational & HTTP only, limited in the schema
But unfortunately it isn’t. But thankfully we have a test for that. So that's another bug (we were silently ignoring the value)
So the work for 4.3 would be
Add a `
setFailFastInitialize(boolean)
to the stored connector and immediately mark it deprecatedMake the Computed ID parser inherit correctly
In V5 we
remove the
fastFailInitialize
from the schemaand make the Computed ID parser inherit correctly
Rod WiddowsonNovember 2, 2022 at 4:45 PM
Confirming that the obvious fix does work.
If this is a bug we need to retrofit it to V4 I guess (but I’ll give it a different Jira entry for clarity)
Note sure if this is meant or not but the outcome is that (at least)
ComputedId
data connectors (and probably many, many more) do not honourexportAttributes
failoverDataConnector
noRetryDelay
and so forth.If this isn’t meant it should/might be an easy fix.
I'll start this off with @Scott Cantor and he can assign it to me to fix if he agrees that this is wrong